Jump to content

Welcome, Guest!

thompson

Cannot SSH or communicate with Pi

Recommended Posts

So after months of flawless operation I noticed I couldn't ssh to my Pi about 2 weeks ago. Activity & networking lights were running, everything appeared okay. So I just hard restarted it and she came back, but a few days later it happened again.

 

I run it headless with a few daemons running (transmission, openvpn, samba, ftp, etc).

 

Here's the message I get when I try to ssh to the Pi using connectbot on my androids:

 

connecting to 192.168.192.100:1773 via ssh

Connection Lost

Failed to connect to 192.168.192.100/192.168.192.100 (port 1773): connect failed: EHOSTUNREACH (No route to host)

 

But now even powering it off doesn't bring back connectivity, it just immediately goes to that. I tried reformatting the SD card on a whim, as well as trying a more robust power supply (neither of which seemed to have any positive effect). I've also ran apt-get update, upgrade & dist-upgrade just to see and it also had no effect.

 

I have a suspicion that openvpn or part of transmission is to blame, but last time I was able to gain access I killed both & it still ended up error'ing minutes later. I did make some changes to IPTables to allow external access while still channeling other traffic through the vpn and also suspect this is part of it (the "failed to connect to 192.168.192.100/192.168.192.100 (port 1773)" doesn't seem like my internal ip should be there twice).

 

Any help is greatly appreciated as I'm a bit lost atm, I do know it's driving me crazy.

Share this post


Link to post
Share on other sites

A couple of things to try

 

1. That the LAN ip is correct. Try ping instead of ssh, look in your router attached devices and see if the

pi is still at 192.168.192.100.

 

2. Add a display/kbd to it, login and run ifconfig

 

3. Download a new raspbian on another sd card, use it to boot and see if the pi hardware is working.

It could be that your sd card is toast.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

About Us

Bringing you the latest Raspberry Pi news, tutorials and user forum.

The Fruity Computer

×
×
  • Create New...