Jump to content

Primary: Sky Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Secondary: Sky Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Squares Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Photo

usb wifi y monitor por vga no me funcionan.


  • Please log in to reply
No replies to this topic

#1
Frambuesita

Frambuesita

    Newbie

  • Members
  • Pip
  • 1 posts
  • Locationespaña

Hola que hay, soy nuevo en esto de la frambuesa y la tengo desde el miercoles de la semana pasada y bueno desde que la tengo, me enamore locamente de ella, por eso me he puesto mi frambuesita, jajaja, bueno al grano:

Mi monitor tiene conexion DVI y conexion VGA, una de cada, la DVI la quiero dejar para el PC de sobremesa y la VGA la quiero usar para la Raspberry (en adelante RP), tambien llevo la idea de conectar por SSH, pero eso despues.

La RP, la quiero en principio, ¿para que puedes querer una RP?, pues para trastear, ¿no?, jajajaj. La idea principal es usarla para P2P y para el JD y como es logico, una vez conseguido ese objetivo, probarla como centro multimedia en la TV, etc

Los dos unicos problemas que tengo, ahora mismo, es que no me funciona el monitor mediante VGA y que el usb wifi tampoco consigo que me funcione de ninguna de las maneras, he buscado en google dios y ayuda de ambos temas, llevo desde que la recibí con estos dos temas y me ha sido totalmente imposible a pesar que he encontrado diversa información, pero nada.

Os muestro los componentes, para que así sepais cuales son, lo he comprado todo en http://www.raspipc.es, decir que estoy encantado con esta gente, un servicio realmente inmejorable.

La fuente es esta:

http://www.raspipc.e... ... ducto=1026

El conversor HDMI-VGA, es este:

http://www.raspipc.e... ... ducto=1083

Y el USB-WIFI es este:

http://www.raspipc.e... ... ducto=1035

Como veis, son productos testados en la RP, asi que deben de funcionar.

Los problemas los estoy teniendo con el vga y con el wifi, navegar navego, pero con cable y la pantalla, de momento, la manejo con DVI-HDMI, pero la idea es conectarlo a vga y dejar en DVI el ordenador grande, asi si tengo la frambuesita puesta con encender el monitor, si esta el grande apagado, pues ya veo lo que ocurre.

Hasta que no consiga que funcione, pues ahora mismo es un latazo, porque tengo que desconectar el monitor del pc grande y conectar la RP y asi sucesivamente y no es la mejor idea.

Cuando consiga conectarlo con VGA y que me funcione el wifi, entonces la idea es conectarlo tambien por ssh, pero eso es lo ultimo, ahora os explico lo del monitor, siguiendo lo que explica aqui:

http://deeiivid.word... ... i-espanol/

En principio funciona, pero cuando apago la RP y la vuelvo a encender, entonces ya no funciona, encambio reiniciando si, osea aclarando, la conecto por DVI-HDMI, quito las almohadillas tal como el comenta y claro al reiniciar se ha cambiado la resolucion, buscando y buscando, los valores adecuados son:

hdmi_group: 2
hdmi_mode: 82

Mi monitor es de resolucion 1920 X 1080

Sigo aun con el cable DVI-HDMI, ahora encaliente, osea sin apagar la RP, cambio de cable y lo conecto al VGA y lo detecta bien y reinicio la RP, las veces que haga falta con el VGA conectado y funciona de maravilla, pero encuanto apago la RP y vuelvo a encender, pues nada, la pantalla en negro y tengo que volver a conectarla por DVI-HDMI, ya he buscado por google como un loco y no he conseguido nada, el motivo de no acudir a foros, desdel el miercoles pasado que la tengo, ha sido porque queria hacerlo todo por mi mismo, googleando, para molestar lo menos posible, pero lo he intentado y no he podido.

Os pongo el archivo /boot/config.txt, para que lo reviseis si lo veis oportuno, tan solo he cambiado los apartados que explicaban en el link:

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=82

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1000

# for more options see http://elinux.org/RPi_config.txt
core_freq=500
sdram_freq=600
over_voltage=6

Con el wifi no os pongo todo lo que he probado, porque ni lo se, he probado cuarenta mil configuraciones diferentes de cuarenta mil sitios encontrado en google y ya estoy mareao, afortunadamente uno de los sitios que encontré, hacia backup de los interfaces, asi que guarde el interfaces original y almenos navegar con cable navego, gracias a que restaure de nuevo el interface, el cual os pongo ahora: /etc/network/interfaces:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Y de momento eso es todo, que no es poco.

Mil gracias y perdonad por tanto calentamiento de cabeza, la verdad que lo he intentado pero me ha sido totalmente imposible.

Saludos.